Commercial Salmon Trolling Forum

comnav

Troubleshooting, repair, and how-to's related to marine systems.

comnav

Postby lone eagle » Wed Jun 24, 2015 12:14 pm

Our local dealer has everyone using them and they don't come cheap. Mine failed on the grounds and was sent back to Canada 4 1/2 weeks ago. No word from anyone. Pretty poor service I'm thinking,
lone eagle
Member
 
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Location: Bandon Or

Re: comnav

Postby Crawfish » Thu Jun 25, 2015 11:56 am

Did you call Comnav?

I would like to think they would have gotten it back to you in a week not over a month. What is wrong with your pilot? I have a Comnav and luckily its worked well so far. Four and half weeks is terrible turnaround.
Crawfish
Site Supporter
Site Supporter
 
Posts: 160
Joined: Tue Feb 11, 2014 11:00 am

Re: comnav

Postby lone eagle » Thu Jun 25, 2015 6:39 pm

I have the "commander" model. The display goes blank and alarm sounds from the computer. Local electronics dealer thinks it may be a processor malfunction and sent it away. Another bummer is that I just spent $850 on a remote . The clock still ticking.. now 5 weeks since he took it. That could kill your year in Alaska. A loaner would be good service.
lone eagle
Member
 
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Location: Bandon Or

Re: comnav

Postby Crawfish » Fri Jun 26, 2015 7:28 am

That sucks. I would be all over them. It's hard enough to make it without equipment failures let alone 5 week repair times.
That's crazy.
Crawfish
Site Supporter
Site Supporter
 
Posts: 160
Joined: Tue Feb 11, 2014 11:00 am

Re: comnav

Postby Robot » Fri Jun 26, 2015 7:34 am

I'm in the same boat as you eagle. I have the comnav p2 commander. Had it sent to combat for diagnostics and repairs and have been fishing without it for 4 weeks now. I leave tomorrow to head out to the coast for the summer King opening and am still without it. Going to be a long drive by hand... No contact or anything from them.
Robot
Site Supporter
Site Supporter
 
Posts: 34
Joined: Sun Mar 09, 2014 8:07 am

Re: comnav

Postby Lulu » Sun Jul 05, 2015 1:44 pm

Sounds like you need a new dealer. I've had Comnav for 6 years with few problems. Usually its a fuse on the main board or a resister. I carry a spare board and upgraded the fuse to slow burn 30 amp on the recommendations of the tech that services the unit. I know all about hand steering 110 miles by hand in deteriorating sea conditions. Ain't fun. As someone mentioned, call Comnav directly. They're pretty responsive and help as much as they can (604) 233-1805
Lulu
Member
 
Posts: 136
Joined: Sat Jan 03, 2015 10:46 am

Re: comnav

Postby lone eagle » Fri Jul 10, 2015 7:36 pm

I did call them, and they were not responsive at all.
lone eagle
Member
 
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Location: Bandon Or

Re: comnav

Postby Jon » Sat Jul 11, 2015 1:11 pm

Order a replacement with fast shipping. When you receive the repaired one, it's now your backup. Or, you can float it to a friend when theirs goes out. :)
If you enjoy the Salmon Trolling Forum, please Image Your support keeps this site alive. Thanks!
Jon
Member
 
Posts: 331
Joined: Thu Feb 23, 2006 7:41 pm
Location: Portland, OR

Re: comnav

Postby lone eagle » Tue Jul 14, 2015 3:48 pm

I bought a system on Ebay which works fine at a quarter the price. So I'll either keep the comnav as backup or put it up for sale .
lone eagle
Member
 
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Location: Bandon Or


Return to Mechanical & Electrical

Who is online

Users browsing this forum: No registered users and 2 guests