comnav

Troubleshooting, repair, and how-to's related to marine systems.
Post Reply
lone eagle
Member
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Spammer?: No
Location: Bandon Or

comnav

Post by lone eagle »

Our local dealer has everyone using them and they don't come cheap. Mine failed on the grounds and was sent back to Canada 4 1/2 weeks ago. No word from anyone. Pretty poor service I'm thinking,
Crawfish
Site Supporter
Site Supporter
Posts: 160
Joined: Tue Feb 11, 2014 11:00 am
Spammer?: No

Re: comnav

Post by Crawfish »

Did you call Comnav?

I would like to think they would have gotten it back to you in a week not over a month. What is wrong with your pilot? I have a Comnav and luckily its worked well so far. Four and half weeks is terrible turnaround.
lone eagle
Member
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Spammer?: No
Location: Bandon Or

Re: comnav

Post by lone eagle »

I have the "commander" model. The display goes blank and alarm sounds from the computer. Local electronics dealer thinks it may be a processor malfunction and sent it away. Another bummer is that I just spent $850 on a remote . The clock still ticking.. now 5 weeks since he took it. That could kill your year in Alaska. A loaner would be good service.
Crawfish
Site Supporter
Site Supporter
Posts: 160
Joined: Tue Feb 11, 2014 11:00 am
Spammer?: No

Re: comnav

Post by Crawfish »

That sucks. I would be all over them. It's hard enough to make it without equipment failures let alone 5 week repair times.
That's crazy.
Robot
Site Supporter
Site Supporter
Posts: 34
Joined: Sun Mar 09, 2014 8:07 am
Spammer?: No

Re: comnav

Post by Robot »

I'm in the same boat as you eagle. I have the comnav p2 commander. Had it sent to combat for diagnostics and repairs and have been fishing without it for 4 weeks now. I leave tomorrow to head out to the coast for the summer King opening and am still without it. Going to be a long drive by hand... No contact or anything from them.
Lulu
Member
Posts: 136
Joined: Sat Jan 03, 2015 10:46 am
Spammer?: No

Re: comnav

Post by Lulu »

Sounds like you need a new dealer. I've had Comnav for 6 years with few problems. Usually its a fuse on the main board or a resister. I carry a spare board and upgraded the fuse to slow burn 30 amp on the recommendations of the tech that services the unit. I know all about hand steering 110 miles by hand in deteriorating sea conditions. Ain't fun. As someone mentioned, call Comnav directly. They're pretty responsive and help as much as they can (604) 233-1805
lone eagle
Member
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Spammer?: No
Location: Bandon Or

Re: comnav

Post by lone eagle »

I did call them, and they were not responsive at all.
Jon
Member
Posts: 335
Joined: Thu Feb 23, 2006 7:41 pm
Spammer?: No
Location: Portland, OR
Contact:

Re: comnav

Post by Jon »

Order a replacement with fast shipping. When you receive the repaired one, it's now your backup. Or, you can float it to a friend when theirs goes out. :)
lone eagle
Member
Posts: 225
Joined: Sat Jan 10, 2009 4:31 pm
Spammer?: No
Location: Bandon Or

Re: comnav

Post by lone eagle »

I bought a system on Ebay which works fine at a quarter the price. So I'll either keep the comnav as backup or put it up for sale .
Post Reply